Bug 39943

Summary: Suggestion...add HSSF object factory
Product: POI Reporter: Dan P <wimpleshapers>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: enhancement    
Priority: P4    
Version: 2.5-FINAL   
Target Milestone: ---   
Hardware: Other   
OS: other   

Description Dan P 2006-07-02 00:58:32 UTC
Create a POI object factory that would, at a minimum, create cell style and 
font objects based on a configuration file (xml or ini).  This would serve 
three purposes: 1) it would act like an html style sheet and allow you to 
centralize look and feel, 2) would allow for external customization of HSSF 
objects without a recompile, and 3) would remove 5 to 10 lines of code per 
object.  The configuration file could be divided into namespaces (ala log4j), 
allowing for the configuration to be hierarchical (meaning shared objects 
would only have to be defined once).  For example:

   IHSSFObjectFactory factory = HSSFObjectFactory.createFactory("namespace");
   HSSFFont headerFont = factory.createFont("header-font");

I have some sample code, but I'm not sure how I proceed from here.
Comment 1 Yegor Kozlov 2007-01-12 03:00:26 UTC

*** This bug has been marked as a duplicate of 39942 ***