Bug 42041

Summary: Tomcat deployer can not auto create directory "apache-tomcat-6.0.10\conf\Catalina\localhost"
Product: Tomcat 6 Reporter: lizongbo <lizongbo>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P2    
Version: 6.0.10   
Target Milestone: default   
Hardware: PC   
OS: Windows XP   
Attachments: netbeans deploy log
Tomcat error log
run project successed after create "Catalina\localhost" manually

Description lizongbo 2007-04-03 22:21:33 UTC
my operation is follow:

1.unzip netbeans6.0 m8 to D:\Java\netbeans.

2.unzip  apache-tomcat-6.0.10.zip to
D:\Java\netbeans\enterprise4\apache-tomcat-6.0.10.

3.change tomcat-users.xml for add  <user username="ide" password="ide"
roles="manager"/>

4.start up netbeans, add tomcat 6.0 in "Server Manger".

5.create a web application, choose server "Tomcat 6.0"

6.run project, thne failed.

filed log is: 

netbeans log :  

Starting server Tomcat 6.0
Starting Tomcat process...
Waiting for Tomcat...
Tomcat server started.
In-place deployment at D:\Java\netbeans\nbwork\shside\build\web
deploy?config=file:/C:/DOCUME~1/ADMINI~1/LOCALS~1/Temp/context63484.xml&path=/shside
FAIL - Failed to deploy application at context path /shside
D:\Java\netbeans\nbwork\shside\nbproject\build-impl.xml:866: Deployment error:
The module has not been deployed.
See the server log for details.
BUILD FAILED (total time: 40 seconds)


tomcat log:

java.io.FileNotFoundException:
D:\Java\netbeans\enterprise4\apache-tomcat-6.0.10\conf\Catalina\localhost\shside.xml
(&#31995;&#32479;&#25214;&#19981;&#21040;&#25351;&#23450;&#30340;&#36335;&#24452;&#12290;)
        at java.io.FileOutputStream.open(Native Method)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
        at
org.apache.catalina.manager.ManagerServlet.copyInternal(ManagerServlet.java:1570)
        at org.apache.catalina.manager.ManagerServlet.copy(ManagerServlet.java:1530)
        at
org.apache.catalina.manager.ManagerServlet.deploy(ManagerServlet.java:803)
        at org.apache.catalina.manager.ManagerServlet.doGet(ManagerServlet.java:345)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:228)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
        at
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:216)
        at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
        at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:634)
        at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:445)
        at java.lang.Thread.run(Thread.java:619)
2007-4-4 13:08:36 org.apache.coyote.http11.Http11Protocol pause




8. I create 
"D:\Java\netbeans\enterprise4\apache-tomcat-6.0.10\conf\Catalina\localhost"
manually.

9. then rerun project again.

10.Succesfull.


so. maybe this is tomcat deployer's bug  or netbeans's bug???
Comment 1 lizongbo 2007-04-03 22:22:40 UTC
Created attachment 19908 [details]
netbeans deploy log
Comment 2 lizongbo 2007-04-03 22:24:08 UTC
Created attachment 19909 [details]
Tomcat error log
Comment 3 lizongbo 2007-04-03 22:25:08 UTC
Created attachment 19910 [details]
run project successed after create "Catalina\localhost" manually
Comment 4 Shiva Kumar H R 2007-04-04 06:58:32 UTC
Could reproduce the problem. Now investigating as to whether it is a Tomcat
deployer's bug or a Netbeans' bug.

- Shiva
Comment 5 lizongbo 2007-04-04 19:03:23 UTC
It's tomcat deployer's bug:

see: http://issues.apache.org/bugzilla/show_bug.cgi?id=41289
Comment 6 Shiva Kumar H R 2007-04-05 05:57:29 UTC

*** This bug has been marked as a duplicate of 41289 ***