Bug 42069

Summary: datagrid is getting the ArrayList object as string
Product: Taglibs Reporter: Mansour <mansour77>
Component: Sandbox TaglibsAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED WONTFIX    
Severity: major    
Priority: P2    
Version: 1.2.0   
Target Milestone: ---   
Hardware: Other   
OS: Linux   

Description Mansour 2007-04-07 12:29:26 UTC
public void setItems (String value) throws JspException
  {
    Object obj;

    obj = ExpressionLanguageHelper.evalObject ("items", value, this, pageContext);
    if      (obj instanceof Iterator)
      items = (Iterator) obj;
    else if (obj instanceof Object [])
      items = Arrays.asList ((Object []) obj).iterator ();
    else if (obj instanceof Collection)
      items = ((Collection) obj).iterator ();
    else if (obj instanceof Map)
      items = ((Map) obj).values ().iterator ();
    else
      throw (new IllegalArgumentException ());
  }

This code is always throwing an exception. The list I am trying to process works
fine with forEach.  
I am using tomcat 6 , JSTL 1.2.
Comment 1 Henri Yandell 2007-04-08 09:47:34 UTC
*** Bug 42068 has been marked as a duplicate of this bug. ***
Comment 2 Henri Yandell 2009-07-10 00:41:21 UTC
This taglib has been deprecated, so I don't expect to see this worked on.