Bug 42915

Summary: Tomcat Service fails to start and gives JNI errors
Product: Tomcat 6 Reporter: gp <gp>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: major Keywords: ErrorMessage
Priority: P2    
Version: 6.0.9   
Target Milestone: default   
Hardware: Other   
OS: Windows XP   
Attachments: Service JNI errors patch , pl unzip and run deploy.bat

Description gp 2007-07-17 03:41:03 UTC
Tomcat Service fails to start and gives this error
[2007-07-17 11:17:04] [174  javajni.c] [error] The specified module could not be
found.
[2007-07-17 11:17:04] [986  prunsrv.c] [error] Failed creating java 
[2007-07-17 11:17:04] [1260 prunsrv.c] [error] ServiceStart returned 1
Comment 1 gp 2007-07-17 04:02:37 UTC
Created attachment 20521 [details]
Service JNI errors patch , pl unzip and run deploy.bat
Comment 2 Len Popp 2007-07-21 08:48:47 UTC
This sounds like http://issues.apache.org/bugzilla/show_bug.cgi?id=41868
Try the workaround described there: Find msvcr71.dll and copy it to an
accessible directory.
Comment 3 Mark Thomas 2007-09-06 19:09:19 UTC

*** This bug has been marked as a duplicate of 41538 ***