Bug 43058

Summary: Outlines in excel sheets
Product: POI Reporter: Petr Titera <P.Titera>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: 3.0-FINAL   
Target Milestone: ---   
Hardware: Other   
OS: Windows XP   
Attachments: Workbook without guts record

Description Petr Titera 2007-08-08 04:42:47 UTC
I've stumbled upon workbook which gives me:

Exception in thread "main" java.lang.NullPointerException
	at org.apache.poi.hssf.model.Sheet.recalcRowGutter(Sheet.java:3001)
	at org.apache.poi.hssf.model.Sheet.groupRowRange(Sheet.java:2987)
	at org.apache.poi.hssf.usermodel.HSSFSheet.groupRow(HSSFSheet.java:1369)

when I try to create groups in it. It seems to me that generator of this
workbook (CR IX) does not emit GutsRecord.
Comment 1 Petr Titera 2007-08-08 04:59:57 UTC
Created attachment 20614 [details]
Workbook without guts record

Attached file contains typical excel sheet generated from CR XI.
Comment 2 Petr Titera 2007-08-08 05:01:24 UTC
*** Bug 43059 has been marked as a duplicate of this bug. ***
Comment 3 Nick Burch 2008-01-09 05:39:12 UTC
Should now be fixed in trunk (we now add the gutsrecord if it isn't there)