Bug 44200

Summary: Sheet not cloneable when Note added to excel cell
Product: POI Reporter: Steven Geens <Steven.Geens>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: apache
Priority: P3    
Version: 3.0-dev   
Target Milestone: ---   
Hardware: PC   
OS: Windows Server 2003   
Attachments: Testcase for problem

Description Steven Geens 2008-01-10 08:51:57 UTC
When trying to call the clonesheet method for a sheet that contains a note,
the following exception is thrown:
The class org.apache.poi.hssf.record.NoteStructureSubRecord needs to define a
clone method

The problem occured with the latest trunk SVN build (CET 2008/01/10 17:44).

If one tries to reproduce the bug with poi-3.0.2-beta1 or poi-3.0.1-FINAL, bug
31795 seems to occur.

In general it seems to be very similar to bug 31795:
(It also complains about the missing clone method.)
Comment 1 Steven Geens 2008-01-10 08:57:09 UTC
Created attachment 21374 [details]
Testcase for problem

A simple testcase to illustrate the bug.
Code copied from the bug 31795, different excel sheet created.
Comment 2 Yegor Kozlov 2008-01-10 10:05:00 UTC
Fixed

Regards,
Yegor