Bug 45583

Summary: org.apache.poi.hpsf.IllegalPropertySetDataException: The property set claims
Product: POI Reporter: Durga Deep Tirunagari <durgadeep>
Component: HWPFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: blocker CC: dherring
Priority: P1    
Version: 3.0-dev   
Target Milestone: ---   
Hardware: Sun   
OS: SunOS   

Description Durga Deep Tirunagari 2008-08-06 17:47:31 UTC
We are running in to this exception.

org.apache.poi.hpsf.IllegalPropertySetDataException: The property set claims to have a size of 16 bytes. However, it exceeds 16 bytes.
org.apache.poi.hpsf.IllegalPropertySetDataException: The property set claims to have a size of 16 bytes. However,it exceeds 16 bytes.
        at org.apache.poi.hpsf.Section.<init>(Section.java:255)
        at org.apache.poi.hpsf.PropertySet.init(PropertySet.java:454)
        at org.apache.poi.hpsf.PropertySet.<init>(PropertySet.java:249)
        at org.apache.poi.hpsf.PropertySetFactory.create(PropertySetFactory.java:61)
        at org.apache.poi.POIDocument.getPropertySet(POIDocument.java:135)
        at org.apache.poi.POIDocument.readProperties(POIDocument.java:99)
        at org.apache.poi.hwpf.HWPFDocument.<init>(HWPFDocument.java:168)
        at org.apache.poi.hwpf.HWPFDocument.<init>(HWPFDocument.java:152)
        at org.apache.poi.hwpf.extractor.WordExtractor.<init>(WordExtractor.java:57)
        at com.sun.comms.iss.indexapi.converter.MSWordConverter.getObject(MSWordConverter.java:123)
        at com.sun.comms.iss.indexapi.converter.ConverterBase.getAttachmentObject(ConverterBase.java:103)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.mimePartAnalyzer(CreateEmailDocument.java:620)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmailContent(CreateEmailDocument.java:452)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:390)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmailContent(CreateEmailDocument.java:479)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:570)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.parseEmail(CreateEmailDocument.java:345)
        at com.sun.comms.iss.indexapi.parser.CreateEmailDocument.createFromMessageObject(CreateEmailDocument.java:118)
        at com.sun.comms.iss.indexapi.parser.EmailParser.setFirstEDoc(EmailParser.java:522)
        at com.sun.comms.iss.indexapi.parser.EmailParser.indexFolder(EmailParser.java:409)
        at com.sun.comms.iss.indexapi.parser.EmailParser.bootstrapEvent(EmailParser.java:232)
        at com.sun.comms.iss.indexapi.parser.EmailParser.processEvent(EmailParser.java:132)
        at com.sun.comms.iss.indexapi.IndexImpl.index(IndexImpl.java:63)
        at com.sun.comms.iss.indexapi.IndexSvcBootstrap.main(IndexSvcBootstrap.java:215)
Aug 6, 2008 5:20:05 PM com.sun.comms.iss.indexapi.converter.MSWordConverter getObject
WARNING: MSWord Attachment : Error Creating WordExtractor Object: org.apache.poi.hpsf.IllegalPropertySetDataException: The property set claims to have a size of 16 bytes. However, it exceeds 16 bytes. NameOfAttachment :
Comment 1 Yegor Kozlov 2009-04-20 11:10:59 UTC
Please upload the problem file. Without the file we can't do much to help you.

Yegor
Comment 2 Maxim Valyanskiy 2009-08-14 04:26:22 UTC
org.apache.poi.hpsf.IllegalPropertySetDataException: The property set claims to have a size of 16 bytes. However, it exceeds 16 bytes.
	at org.apache.poi.hpsf.Section.<init>(Section.java:253)
	at org.apache.poi.hpsf.PropertySet.init(PropertySet.java:452)
	at org.apache.poi.hpsf.PropertySet.<init>(PropertySet.java:247)
	at org.apache.poi.hpsf.PropertySetFactory.create(PropertySetFactory.java:59)
	at org.apache.poi.POIDocument.getPropertySet(POIDocument.java:135)
	at org.apache.poi.POIDocument.readProperties(POIDocument.java:99)
	at org.apache.poi.hwpf.HWPFDocument.<init>(HWPFDocument.java:173)
	at org.apache.poi.hwpf.HWPFDocument.<init>(HWPFDocument.java:157)

(SVN trunk 14/08/2009)

Unfortunatelly file is too big for bugzilla, download it here: http://maxcom.pp.ru/other/tmp/fail.doc
Comment 3 Yegor Kozlov 2009-08-20 06:50:33 UTC
*** Bug 42726 has been marked as a duplicate of this bug. ***
Comment 4 Yegor Kozlov 2009-08-20 07:03:40 UTC
Fixed in r806172

the fix consists of two parts: 
 - improved reading of the ClipboardData packet in OLE property sets - it was
the actual reason of the exception
 - changed HWPF (and other modules) to read OLE properties on demand, not when
constructing documents. HSSF already uses this lazy approach and it makes sense
be consistent across all POI modules. 

Regards,
Yegor