Bug 46445

Summary: shiftRows does not move hyperlinks
Product: POI Reporter: Antti Koskimäki <antti.koskimaki>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: 3.5-dev   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Attachments: excel and sourcecode to reproduce bug

Description Antti Koskimäki 2008-12-29 22:17:32 UTC
Created attachment 23060 [details]
excel and sourcecode to reproduce bug

Both excel-made and POI-made hyperlinks remain in their original positions when shifting rows with shiftRows. This results cell with link label to be placed different location than cell acting as link.

Source and excel to re-produce attached
Comment 1 Antti Koskimäki 2008-12-29 22:50:33 UTC
Tested with latest r729456 
Comment 2 Yegor Kozlov 2008-12-29 23:09:04 UTC
it seems to be related to #29957
Comment 3 Yegor Kozlov 2008-12-30 01:24:37 UTC
Fixed in r730076