Bug 46817

Summary: Regression: Text from some table cells missing
Product: POI Reporter: Aleksander Zawitkowski <olek>
Component: HWPFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: andremoniy
Priority: P2    
Version: 3.5-dev   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
URL: http://www.bip.cekcyn.pl/upload/103/Informacja_o_wyniku_przetargu.doc

Description Aleksander Zawitkowski 2009-03-06 14:46:26 UTC
The text got extracted completely (out of order, however) from the above document until revision 684986. I'm still getting this error with the latest checkout.

------------------------------------------------------------------------
r684986 | nick | 2008-08-12 01:42:39 +0200 (Tue, 12.08.2008) | 1 line

Finally get all HWPF tests to pass again, by working around how evil PAPX/CHPX/SEPX byte references are
Comment 1 Andremoniy 2009-07-08 03:03:32 UTC
I suspect, that this bug is related with  Bug 47496
Comment 2 Yegor Kozlov 2011-06-24 08:18:39 UTC
The problem is still reproducible in trunk.

Yegor
Comment 3 Sergey Vladimirov 2011-07-05 03:17:26 UTC
According to doc file dump, part starting with "Nazwa wykonawcy..." is not a textual part, but some kind of embedded object (SHAPE).

is it embedded doc / excel or something like OLE object?
Comment 4 Sergey Vladimirov 2011-07-07 11:40:47 UTC
Fixed in r1143769, shall be part of poi 3.8-beta4