Bug 47724

Summary: Unit-test failure on truck 24/aug/2009
Product: POI Reporter: Maxim Valyanskiy <max.valjanski>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED WORKSFORME    
Severity: normal    
Priority: P2    
Version: 3.5-dev   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
Attachments: build/test-results/TEST-org.apache.poi.hssf.usermodel.TestHSSFSheet.txt

Description Maxim Valyanskiy 2009-08-24 03:50:09 UTC
[junit] Running org.apache.poi.hssf.usermodel.TestHSSFSheet
    [junit] Tests run: 20, Failures: 1, Errors: 0, Time elapsed: 0.132 sec

BUILD FAILED
/home/maxcom/git-checkout/poi/build.xml:566: Tests failed
Comment 1 Maxim Valyanskiy 2009-08-24 03:51:41 UTC
Created attachment 24157 [details]
build/test-results/TEST-org.apache.poi.hssf.usermodel.TestHSSFSheet.txt
Comment 2 Yegor Kozlov 2009-08-24 04:32:30 UTC
Clean your build directory and try again. There was a big refactoring of test classes over weekend and stale stuff in the build directory can cause errors. 

I've just tried "ant test" with JDK 1.6.13  on Windows and SunOS and it worked fine to me. 

Yegor
Comment 3 Maxim Valyanskiy 2009-08-24 05:32:20 UTC
I found that test work on:

java version "1.6.0_05"
Java(TM) SE Runtime Environment (build 1.6.0_05-b13)
Java HotSpot(TM) Client VM (build 10.0-b19, mixed mode, sharing)

and fails on 

java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.5) (fedora-27.b16.fc11-i386)
OpenJDK Client VM (build 14.0-b15, mixed mode)

May be It is caused by bug in OpenJDK
Comment 4 Dominik Stadler 2013-08-05 09:46:10 UTC
no response in a long time => resolving for now, please reopen with more information if this is still an issue, we probably require a recent patched jdk and should not handle jdk bugs specifically