Bug 47870

Summary: JMSSubscriber fails due to NPE
Product: JMeter Reporter: Philippe Mouawad <p.mouawad>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: RESOLVED FIXED    
Severity: normal CC: hikiran
Priority: P2    
Version: 2.3.4   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
URL: http://www.ubik-ingenierie.com
Attachments: Corrects NPE

Description Philippe Mouawad 2009-09-18 07:48:01 UTC
Created attachment 24292 [details]
Corrects NPE

Hello,
When you use JMSSubscriber you always get NPE exception at line 87 in trunk
head (198/09/2009)
Investigating a little it seems that _CONN and _SESSION where accessed  before
being initialized.

Attached is a patch that corrects the issue.
By the way close method should try/catch different close method to ensure no
leak.

Philippe
http://www.ubik-ingenierie.com
Comment 1 Sebb 2009-09-19 07:16:55 UTC
Thanks very much for the patch; applied to SVN:

URL: http://svn.apache.org/viewvc?rev=816929&view=rev
Log:
Bug 47870 - JMSSubscriber fails due to NPE
Comment 2 Sebb 2009-09-24 09:22:46 UTC
*** Bug 47899 has been marked as a duplicate of this bug. ***