Bug 47899

Summary: NullPointerExceptions in ReceiveSubscriber constructor
Product: JMeter Reporter: Hiskill <hikiran>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: RESOLVED FIXED    
Severity: critical    
Priority: P2    
Version: 2.3.4   
Target Milestone: ---   
Hardware: All   
OS: All   
Attachments: patch NPE at #88

Description Hiskill 2009-09-24 08:44:22 UTC
I was testing out JMS Topics with Jemeter and started seeing NPEs.
org.apache.jmeter.protocol.jms.client.RecieveSubscriber constructor seems to refer to variables this.CONN,this.TOPIC,this.SESSION before they were assigned values which caused NPEs, I had to fix them in the source and rebuild to make it working.  

Looks like JMS Topics were not tested out.

Fixes need to be made at line#87 and line#88
Comment 1 Sebb 2009-09-24 09:22:46 UTC

*** This bug has been marked as a duplicate of bug 47870 ***
Comment 2 Hiskill 2009-09-24 13:40:55 UTC
Created attachment 24308 [details]
patch NPE at #88

I looked at the checkin, this would still give an NPE at #88.

Line:
_subscriber = _session.createSubscriber(this.TOPIC);

Should have been:
_subscriber = _session.createSubscriber(_topic);


Attached the source file.
Comment 3 Sebb 2009-09-24 14:05:49 UTC
Oops! I changed the previous patch (incorrectly), so here is another try:

URL: http://svn.apache.org/viewvc?rev=818624&view=rev
Log:
Bug 47899 -  NullPointerExceptions in ReceiveSubscriber constructor

Is that OK?
Comment 4 Hiskill 2009-09-25 07:48:42 UTC
looks great now, thanks for the fix.
Comment 5 Hiskill 2009-09-30 09:36:57 UTC
Sebb seems to have fixed this now (thanks!)