Bug 48262

Summary: Not implemented function 'TRUNC'
Product: POI Reporter: werlitz
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: werlitz
Priority: P2    
Version: 3.5-FINAL   
Target Milestone: ---   
Hardware: All   
OS: All   

Description werlitz 2009-11-23 05:20:51 UTC
Please add support for the function 'TRUNC'.

Caused by: org.apache.poi.ss.formula.eval.NotImplementedException: TRUNC
	at org.apache.poi.hssf.record.formula.functions.NotImplementedFunction.evaluate(NotImplementedFunction.java:42)
	at org.apache.poi.hssf.record.formula.eval.FunctionEval.evaluate(FunctionEval.java:247)
	at org.apache.poi.ss.formula.WorkbookEvaluator.evaluateFormula(WorkbookEvaluator.java:374)
	at org.apache.poi.ss.formula.WorkbookEvaluator.evaluateAny(WorkbookEvaluator.java:257)
	... 45 more
Comment 1 Yegor Kozlov 2011-06-20 15:57:51 UTC
TRUNC is implemented in 3.8-beta3.

Yegor