Bug 49647

Summary: MailSessionFactory, et al missing in Tomcat 5.5.30
Product: Tomcat 5 Reporter: Adam Rauch <adam>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: regression CC: adam
Priority: P2    
Version: 5.5.30   
Target Milestone: ---   
Hardware: PC   
OS: other   

Description Adam Rauch 2010-07-26 01:35:22 UTC
OS is Windows 7 (which probably could be added to your OS list now).

5.5.30 appears to have reintroduced this bug: https://issues.apache.org/bugzilla/show_bug.cgi?id=40668

Comparing naming-factory.jar in Tomcat 5.5.29 with the one distributed in Tomcat 5.5.30 confirms that the following classes are missing:

 SendMailFactory
 SendMailFactory$1
 MailSessionFactory
 MailSessionFactory$1
 MailSessionFactory$2

As a result, sending email from our Tomcat application is completely broken.
Comment 1 Rainer Jung 2010-07-26 05:45:36 UTC
Confirmed.

I checked all the jar files, those are the only classes missing, all other changes are as expected.

container/catalina/build.xml builds the classes if property compile.javamail is set, which is true if either full.dist=="on" or javamail.present is set. The latter is true, if it finds "javax.activation.DataSource" in activation.jar and "javax.mail.Service" in mail.jar. Both are not part of the download target, possibly because of licensing. So I guess they were not present on the build machine.

We need better release documentation for TC 5.5, release process seems to be to fragile. There are lots of other dynamically determined conditions in the build.xml files.
Comment 2 Mark Thomas 2010-09-17 03:12:42 UTC
5.5.31 has been released that fixes this.