Bug 49796

Summary: Crash in SSLSocket.handshake()
Product: Tomcat Native Reporter: mikew
Component: LibraryAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P2    
Version: 1.1.20   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
Attachments: stack dump

Description mikew 2010-08-22 01:42:00 UTC
Created attachment 25925 [details]
stack dump

This is with APR 1.4.2 on Linux (CentOS 5.3).  (Also using Tomcat 6.0.29 and Tomcat Native 1.1.20.)

I don't know how to reproduce this, but I hope that the attached stack dump may point to the problem.

This is a different seg fault / stack trace from Bug 49795.
Comment 1 Rainer Jung 2010-08-22 01:57:22 UTC
Moved from APR to Tomcat. I expect this needs investigation in tcnative.
See also BZ 49795, there's possibly a common root cause.
Comment 2 mikew 2010-08-22 10:12:05 UTC
I just noticed "java.io.IOException: Too many open files" in the Tomcat log.  So the problem might be that either Tomcat Native or APR is not gracefully handling a system call failure.

Regarding whether or not this bug is related to Bug 49795, here is how the situations are similar and different:

Similarities: The 2 systems are running the exact same versions of Java, Tomcat, Tomcat Native and APR.

Differences: The 2 bugs occurred on 2 different systems, and happened about 2 hours apart. The systems have slightly different Linux kernel versions.  The systems that exhibited this bug had "java.io.IOException: Too many open files" in the server log, while the other system did not.  (However, it is conceivable that the system for Bug 49795 ran out of file descriptors but did not manage to log that fact.  But I would not assume this.)
Comment 3 Mark Thomas 2010-09-28 17:46:37 UTC
Moving to native
Comment 4 jfclere 2011-01-12 03:14:30 UTC
Looks like 49795... If not reproducible it is hard to investigate

*** This bug has been marked as a duplicate of bug 49795 ***