Bug 50142

Summary: OutOfMemory using XSLT.
Product: Fop - Now in Jira Reporter: rafael.detter
Component: pdfAssignee: fop-dev
Status: CLOSED INVALID    
Severity: normal CC: rafael.detter
Priority: P2 Keywords: XSLTBug
Version: 0.93   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   

Description rafael.detter 2010-10-22 07:56:19 UTC
I´m trying to render XML into PDF using a XSLT template and it gives me back an OutOfMemory exception when I try to render more than 3500 registry information.

Could anyone please help me ?

Thanks in advande.
Comment 1 Glenn Adams 2010-10-22 09:44:59 UTC
Not a bug. Increase your JVM memory by using the 'java' command's -Xmx option or equivalent.
Comment 2 rafael.detter 2010-10-22 11:32:06 UTC
I am already using 512mb of memory for the JVM.
Comment 3 rafael.detter 2010-10-22 14:35:14 UTC
I was looking for a solution ans I found about split the page sequnce; how can I set the page-sequence for 10 pages?

tks
Comment 4 Glenn Adams 2010-10-22 20:10:15 UTC
Try 1024m or 2048m, etc. Try reducing your input to distinct subsets run with distinct FOP instances.

(In reply to comment #2)
> I am already using 512mb of memory for the JVM.
Comment 5 Vincent Hennebert 2010-10-25 06:35:53 UTC
Please ask questions on the fop-users mailing list:
http://xmlgraphics.apache.org/fop/maillist.html#fop-user

Thanks,
Vincent
Comment 6 Glenn Adams 2012-04-01 13:42:41 UTC
batch transition to closed for remaining resolved bugs