Bug 50406

Summary: init() doesn't initialize connector any more
Product: Tomcat 7 Reporter: Mladen Turk <mturk>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: regression    
Priority: P2    
Version: trunk   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description Mladen Turk 2010-12-03 03:33:30 UTC
Recent change of moving connectors init() code to start()
makes Tomcat unusable under commons-daemon.
This is severe regression cause sockets are now bind in start
method when the privileges are already dropped.
Comment 1 Christopher Schultz 2010-12-03 10:40:44 UTC
How about adding a method:

public void initAndStart()
{
  init();
  start();
}

Commons-daemon can use that. Of course, this introduces an API incompatibility and users will have to have a minimum commons-daemon version to work properly with TC 7.0.x.

Or would it be better to revert the recent patch and create new methods with different semantics? Since TC 7 is not considered stable (yet), it seems okay to change the API like this. On the other hand, it impacts an external project.
Comment 2 Mark Thomas 2010-12-03 13:09:07 UTC
Breaking change reverted.