Bug 50588

Summary: Caused by: java.lang.NoSuchMethodError: org.apache.poi.hssf.usermodel.HSSFDateUtil.isCellDateFormatted(Lorg/apache/poi/hssf/usermodel/HSSFCell;)Z
Product: POI Reporter: Karthik Rengasamy <Karthik.rengasamy>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED INVALID    
Severity: major CC: Karthik.rengasamy
Priority: P2    
Version: 3.7-FINAL   
Target Milestone: ---   
Hardware: Other   
OS: Linux   

Description Karthik Rengasamy 2011-01-14 17:42:51 UTC
We are using old version of Poi 2.5 in the application .
We recently planned to migrate to latest version poi 3.7 .

I am facing the Following error 


Caused by: java.lang.NoSuchMethodError: org.apache.poi.hssf.usermodel.HSSFDateUtil.isCellDateFormatted(Lorg/apache/poi/hssf/usermodel/HSSFCell;)Z


Nothing has changed in Code .it works fine with poi 2.5 

I have downloaded the binary distribution from Apache 
I deleted the 2.5 jar in the web application and just moved the latest 3.7 jar alone poi-ooxml-3.7-20101029.jar


Thanks ,
Karthik
Comment 1 Karthik Rengasamy 2011-01-14 17:46:46 UTC
I explored the 3.7 jar and found the class HSSFDateUtil .It extends  org.apache.poi.ss.usermodel.DateUtil;

and i can see the method isCellDateFormatted in it .

But still it doesnt works .
Comment 2 David Fisher 2011-01-14 17:54:40 UTC
Hi Karthik,

Have a look at these resources:

http://poi.apache.org/faq.html
http://poi.apache.org/spreadsheet/quick-guide.html
http://poi.apache.org/spreadsheet/converting.html

Please ask for specific help with updating from 2.5 to 3.7 on the users list. Include some examples of the code you are using in 2.5.

You will certainly need to assure that you recompile your code without the 2.5 jars in your classpath.

Regards,
Dave
Comment 3 Nick Burch 2011-01-14 17:55:11 UTC
Binary compatibility is not supported for jumps that large (it's almost 7 years since poi 2.5!)

You'll need to recompile your application against the new jars