Bug 51613

Summary: SXSSF doesn't work wit java 5
Product: POI Reporter: Juri <juri.krainjukov>
Component: SXSSFAssignee: POI Developers List <dev>
Status: RESOLVED LATER    
Severity: normal    
Priority: P2    
Version: 3.8-dev   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description Juri 2011-08-04 09:53:50 UTC
Exception is thrown when writing to stream.
TreeMap does have firstEntry method in java 6 but not in java 5



java.lang.NoSuchMethodError: java.util.TreeMap.firstEntry()Ljava/util/Map$Entry;
	at org.apache.poi.xssf.streaming.SXSSFSheet.flushOneRow(SXSSFSheet.java:1203)
	at org.apache.poi.xssf.streaming.SXSSFSheet.flushRows(SXSSFSheet.java:1199)
	at org.apache.poi.xssf.streaming.SXSSFSheet.getWorksheetXMLInputStream(SXSSFSheet.java:61)
	at org.apache.poi.xssf.streaming.SXSSFWorkbook.injectData(SXSSFWorkbook.java:108)
	at org.apache.poi.xssf.streaming.SXSSFWorkbook.write(SXSSFWorkbook.java:496)
Comment 1 Yegor Kozlov 2011-08-04 10:18:26 UTC
TODO for upcoming 3.8-beta4

Yegor
Comment 2 Nick Burch 2011-08-04 11:10:21 UTC
Could you confirm if you've tried with a recent nightly build? Only I seem to recall fixing one of these issues a few weeks back
Comment 3 Juri 2011-08-04 11:18:40 UTC
No, haven't tried
Comment 4 Juri 2011-08-04 11:54:27 UTC
Thanks. It works with nightly build.