Bug 52259

Summary: synchonization issues and dead lock if no realm is presented in configuration
Product: Tomcat 7 Reporter: John <a19596>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Severity: major CC: zhouyanming
Priority: P2    
Version: 7.0.23   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description John 2011-11-28 19:32:12 UTC

Tomcat 7.0.23 startup freezes at "INFO: Deploying web application directory ..."

- no errors are displayed in logs
- tomcat process can't be shutted down with shutdown.sh script
- http request on 80 port wait forever
- it's a multi host configuration
- the same setup works well on all previous build, including 7.0.22
- when lib/*.jar files of tomcat-7.0.23 are replaced with lib/*.jar files of tomcat-7.0.23 - everything works just fine

fix it asap!
thank you!

fill free to contact for details: a19596@mail.ru
Comment 1 Mark Thomas 2011-11-28 19:55:46 UTC
Bugzilla is not a support forum. Please use the users mailing list.
Comment 2 John 2011-11-28 21:26:56 UTC
it's not a support issue, it's a bug that somebody of programmers have made developing from 7.0.22 to 7.0.23. fix it asap. thanks.
Comment 3 John 2011-11-28 21:51:47 UTC
the correct webapp works on <=7.0.22 and doesn't work on 7.0.23. IS IT A SUPPORT ISSUE? i guess not. fix it.
Comment 4 Mark Thomas 2011-11-28 21:58:23 UTC
This works for everyone else including the ASF Jira instance and the full TCK suite. You have misconfigured your server. That is not a bug. Further support is available from the users mailing list.

Please stop re-opening this issue.
Comment 5 John 2011-11-29 11:57:13 UTC
details to reproduce:
Comment 6 Mark Thomas 2011-11-29 19:10:23 UTC
Good to see that the users mailing list has done its job and we now have a valid bug report. Thanks are due to Michael Zampani who took the time to do some investigation and provided the necessary steps to reproduce the issue as well as a potential work-around.

This appears to be a regression caused by the new threaded deployment (bug 46264).

The syncs in ContainerBase all need to be reviewed as there may be other potential deadlock triggers.
Comment 7 Mark Thomas 2011-11-29 19:59:28 UTC
Fixed in trunk and 7.0.x and will be included in 7.0.24 onwards.
Comment 8 John 2011-12-01 20:54:42 UTC
Good to see you have finally fixed the bug :)
Comment 9 Rainer Jung 2011-12-02 08:58:03 UTC
*** Bug 52276 has been marked as a duplicate of this bug. ***