Bug 52645

Summary: Recording with Proxy leads to OutOfMemory
Product: JMeter Reporter: Philippe Mouawad <p.mouawad>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: RESOLVED FIXED    
Severity: normal CC: p.mouawad
Priority: P2    
Version: 2.6   
Target Milestone: ---   
Hardware: All   
OS: All   
Attachments: Leak

Description Philippe Mouawad 2012-02-12 21:50:36 UTC
Created attachment 28303 [details]
Leak

Reproduction scenario:
- Setup a Proxy pointing to a Recording Controller
- Setup a recording controller

I start recording, after around 100 requests (not including embedded resources), I got an OOM.
Analyzing Heap Dump, I found an array of 5594  PropertyChangeListener taking around 347Mb. 

Even if I clean nodes in Tree of Test Plan, no memory is cleaned up and these leaks stay.
Comment 1 Philippe Mouawad 2012-02-12 21:51:04 UTC
Issue is also on JMeter 2.5.1
Comment 2 Philippe Mouawad 2012-02-29 08:49:32 UTC
Fixing issue 52788 fixed this one.
Memory leak was due to GUI being built out of AWT Thread.

I decided not to mark this one as duplicate of 52788 cause users will face rather this one than the 52788.


Date: Tue Feb 28 16:01:05 2012
New Revision: 1294708

URL: http://svn.apache.org/viewvc?rev=1294708&view=rev
Log:
Bug 52788 - HttpRequestHdr : Optimize code to avoid useless work

Modified:
   jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/proxy/HttpRequestHdr.java
   jmeter/trunk/xdocs/changes.xml


Date: Wed Feb 29 08:44:41 2012
New Revision: 1295013

URL: http://svn.apache.org/viewvc?rev=1295013&view=rev
Log:
Bug 52645 - Recording with Proxy leads to OutOfMemory

Modified:
   jmeter/trunk/xdocs/changes.xml