Bug 52980

Summary: getAnnotationEntries methods in JavaClass and FieldOrMethod duplicate code
Product: BCEL - Now in Jira Reporter: Chas Honton <charles_honton>
Component: MainAssignee: issues <issues>
Status: NEW ---    
Severity: normal CC: charles_honton
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: Macintosh   
OS: All   
Attachments: refactoring of JavaClass, FieldOrMethod, and AnnotationEntry

Description Chas Honton 2012-03-23 18:47:05 UTC
Created attachment 28504 [details]
refactoring of JavaClass, FieldOrMethod, and AnnotationEntry

JavaClass.getAnnotationEntries() and FieldOrMethod.getAnnotationEntries() are overly complex. 

FieldOrMethod.addAnnotationEntry() appears to be in the wrong place - FieldGenOrMethodGen.addAnnotationEntry() is the proper method to use.