Bug 53154

Summary: Wrong implementation of MessageSubmissionChunk.readValue(InputStream)
Product: POI Reporter: robok
Component: HSMFAssignee: POI Developers List <dev>
Status: RESOLVED LATER    
Severity: normal    
Priority: P2    
Version: 3.8-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description robok 2012-04-27 13:08:23 UTC
Format of the part is l=<id>-<date>-<number> (as it is written in comment), but algorithm fail to parse date correctly when <id> contains '-' character. In our case the part looks like: "SERVER-SBS-120426125432Z-255".
Comment 1 Nick Burch 2012-04-27 13:35:51 UTC
Any chance you could create/share a small test file that shows up the problem? We can then use it to test the fix, and to ensure it doesn't get broken again in the future
Comment 2 Dominik Stadler 2015-03-22 20:32:24 UTC
No test-file available since a long time, therefore hard to reproduce and fix this currently. Please reopen with a sample file if this is still an issue for you.
Comment 3 Adrian Conlon 2016-04-10 18:22:48 UTC
This can be marked as a duplicate of bug 57744.

Apologies for not noticing the connection when I opened #57744...