Bug 53250

Summary: Blocked when instantiate of XSSFExcelExtractor or XSSFWorkbook
Product: POI Reporter: toplinuxer
Component: XSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: critical    
Priority: P2    
Version: 3.8-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description toplinuxer 2012-05-16 23:50:38 UTC
Hi~


when I instantiate XSSFWorkbook or XSSFExcelExtractor for getText().

New instantiate about them is blocked with attached XSLX file.

I write code like below

#
# case 1
#
OPCPackage pkg = OPCPackage.open(fileName);

// blocked below code, no exception.. no response..
XSSFExcelExtractor ext = new XSSFExcelExtractor(pkg);
String fullText = ext.getText();

#
# case 2
#
OPCPackage pkg = OPCPackage.open(fileName);

// blocked below code, no exception.. no response..
XSSFWorkbook wb = new XSSFWorkbook(pkg);
XSSFExcelExtractor ext = new XSSFExcelExtractor(wb);
String fullText = ext.getText();



I will attach problem occurred Excel File.

Would you please quick answer about this problem.. I got critical issue about that.
Comment 1 toplinuxer 2012-05-16 23:56:49 UTC
It's size about 1.3M
so can't upload to site (limit to 1MB ㅠㅠ)

so I attach problem occured Excel file with below link 

http://bit.ly/JU6Ujl
Comment 2 Nick Burch 2012-05-17 02:54:04 UTC
Supplied file opens and extracts just fine for me. POI extracts text which starts with:

표지
master(070428)
	<2007년 04월 24일 기준>
	1. Pipe Line
	(Unit:M Won)
	Territory	January	February	March	1Q	April	May	June	2Q	1H	July	August	September	3Q	1Q ~ 3Q	OctoberNovember	December	4Q	2H	YTD
	06
Act.	Plan	P/L	Act	'06/'07
(etc)

I don't know what you're doing wrong, but I'd double check your JVM is installed and correctly configured, and you've not broken the xml parsing in it
Comment 3 toplinuxer 2012-05-17 03:31:13 UTC
I use jdk1.7.0_03 version.

and what do you mean "correctly configured" ?
Comment 4 toplinuxer 2012-05-17 07:22:03 UTC
my runtime is 
  Windows 7 64bit
  JDK 1.7.0_03 32bit

and your poi 3.8

check it plz..
Comment 5 Nick Burch 2012-05-17 14:32:19 UTC
The POI bugzilla is not the place to ask for help with basic JVM setup queries, try the support forums of whoever makes your JVM. I don't know what you've done wrong, only that POI can handle your file just fine
Comment 6 toplinuxer 2012-05-29 10:54:31 UTC
I think this problem is blocked when instantiate Class
But see long time this problem is not blocking, but needed so many time (1 hours)

About attacked XLSX, instantiate Workbook or XSSFExcelExtractor needed
about 1 hours. (after about 1 hours next code do their works well...)
Similar issue is like below
( http://mail-archives.apache.org/mod_mbox/poi-user/201010.mbox/%3C9C9F7A2C-ECDC-4BAE-AC8E-79A97E762868@jmlafferty.com%3E )


How can I solve this performance issue.

I need a timeout or make a short the latency when instantiate
Comment 7 Yegor Kozlov 2012-10-12 13:15:39 UTC

*** This bug has been marked as a duplicate of bug 51585 ***