Bug 53379

Summary: IndexOutOfBoundsException on MS word 2007 doc
Product: POI Reporter: Tim Barrett <tim.barrett>
Component: HDFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: major    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: Macintosh   
OS: All   
Attachments: offending word document

Description Tim Barrett 2012-06-07 10:37:50 UTC
Created attachment 28900 [details]
offending word document

Error (stack trace heer) when parsing 'old' .doc format word doc. When same doc is saved to docx format, error no longer occurs.
<p class="tOC_3"><i>Exception in thread "main" org.apache.tika.exception.TikaException: Unexpected RuntimeException from org.apache.tika.parser.microsoft.OfficeParser@4c5cc942
	at org.apache.tika.parser.CompositeParser.parse(CompositeParser.java:244)
	at org.apache.tika.parser.CompositeParser.parse(CompositeParser.java:242)
	at org.apache.tika.parser.AutoDetectParser.parse(AutoDetectParser.java:120)
	at org.apache.tika.cli.TikaCLI$OutputType.process(TikaCLI.java:133)
	at org.apache.tika.cli.TikaCLI.process(TikaCLI.java:400)
	at org.apache.tika.cli.TikaCLI.main(TikaCLI.java:101)
Caused by: java.lang.IndexOutOfBoundsException: Index: 151, Size: 79
	at java.util.ArrayList.RangeCheck(ArrayList.java:547)
	at java.util.ArrayList.get(ArrayList.java:322)
	at org.apache.poi.hwpf.model.ListTables.getOverride(ListTables.java:196)
	at org.apache.poi.hwpf.usermodel.Paragraph.newParagraph(Paragraph.java:108)
	at org.apache.poi.hwpf.usermodel.Range.getParagraph(Range.java:890)
	at org.apache.tika.parser.microsoft.WordExtractor.parse(WordExtractor.java:96)
	at org.apache.tika.parser.microsoft.OfficeParser.parse(OfficeParser.java:185)
	at org.apache.tika.parser.microsoft.OfficeParser.parse(OfficeParser.java:160)
	at org.apache.tika.parser.CompositeParser.parse(CompositeParser.java:242)
	... 5 more
Comment 1 Dominik Stadler 2015-03-22 20:42:40 UTC
I verified that text/properties from this document can be extracted successfully.with current POI (3.12-beta1), therefore resolving this as fixed.