Bug 53782

Summary: Enhance JavaSampler handling of JavaSamplerClient cleanup to use less memory
Product: JMeter Reporter: Philippe Mouawad <p.mouawad>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: RESOLVED FIXED    
Severity: enhancement CC: p.mouawad, sebb
Priority: P2    
Version: 2.7   
Target Milestone: ---   
Hardware: All   
OS: All   

Comment 1 Philippe Mouawad 2012-08-25 12:22:54 UTC
Date: Sat Aug 25 12:21:50 2012
New Revision: 1377279

URL: http://svn.apache.org/viewvc?rev=1377279&view=rev
Log:
Bug 53782 - Enhance JavaSampler handling of JavaSamplerClient cleanup to use less memory

First improvement, store only necessary objects
Bugzilla Id: 53782

Modified:
    jmeter/trunk/src/protocol/java/org/apache/jmeter/protocol/java/sampler/JavaSampler.java
Comment 2 Philippe Mouawad 2012-08-25 13:18:25 UTC
Date: Sat Aug 25 13:17:19 2012
New Revision: 1377291

URL: http://svn.apache.org/viewvc?rev=1377291&view=rev
Log:
Bug 53782 - Enhance JavaSampler handling of JavaSamplerClient cleanup to use less memory
Only register instance of JavaSamplerClient that have overriden or implemented teardownTest
Bugzilla Id: 53782

Modified:
    jmeter/trunk/src/protocol/java/org/apache/jmeter/protocol/java/sampler/JavaSampler.java
    jmeter/trunk/xdocs/changes.xml
    jmeter/trunk/xdocs/usermanual/component_reference.xml
Comment 3 Sebb 2012-08-29 11:14:53 UTC
*** Bug 53743 has been marked as a duplicate of this bug. ***