Bug 54034

Summary: org.apache.poi.ss.usermodel.DateUtil.isCellDateFormatted can't work right when excel2007 cell format is "yyyy-MM-ddTHH:mm:ss"
Product: POI Reporter: wangwei <dmxiaolan>
Component: XSSFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: dmxiaolan
Priority: P2    
Version: 3.8-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: All   
Attachments: the sample file
testcase

Description wangwei 2012-10-22 01:23:05 UTC
Created attachment 29504 [details]
the sample file

org.apache.poi.ss.usermodel.DateUtil.isCellDateFormatted can't work right when excel2007 cell format is "yyyy-MM-ddTHH:mm:ss". The method return false that is not right,because we call getDateCellValue() on the Cell object,it return the right java.util.Date.

Use the Book1.xlsx to reproduce it.
Comment 1 wangwei 2012-10-22 01:30:29 UTC
please also check org.apache.poi.ss.usermodel.DataFormatter.formatRawCellContents for format string "yyyy-MM-ddTHH:mm:ss". it can't process it right.
Comment 2 Nick Burch 2012-10-22 09:48:50 UTC
Are you able to create a unit test that shows the problem? (problems?) And does it work for other simpler formats?
Comment 3 wangwei 2012-10-22 10:29:51 UTC
Created attachment 29505 [details]
testcase
Comment 4 wangwei 2012-10-26 06:53:01 UTC
it work for other simpler formats.
Comment 5 Nick Burch 2014-05-23 09:18:32 UTC
Thanks for the testcase for this, fixed in r1597038.