Bug 54414

Summary: Remote Test should not start if one of the engines fails to start correctly
Product: JMeter Reporter: Philippe Mouawad <p.mouawad>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: RESOLVED FIXED    
Severity: enhancement CC: p.mouawad
Priority: P2    
Version: 2.8   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Philippe Mouawad 2013-01-13 15:13:54 UTC
As of JMeter 2.8, when one of the remote engines fails to start, a message is displayed in console:
"Failed to configure ..."

but test is started which seems inappropriate as required load will not be reached.
It is better to throw and exception indicating which engines are misconfigured.
Comment 1 Philippe Mouawad 2013-01-13 15:28:59 UTC
Date: Sun Jan 13 15:28:12 2013
New Revision: 1432638

URL: http://svn.apache.org/viewvc?rev=1432638&view=rev
Log:
Bug 54414 - Remote Test should not start if one of the engines fails to start correctly
Bugzilla Id: 54414

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/JMeter.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2013-01-13 15:32:36 UTC
Date: Sun Jan 13 15:30:49 2013
New Revision: 1432641

URL: http://svn.apache.org/viewvc?rev=1432641&view=rev
Log:
Bug 54414 - Remote Test should not start if one of the engines fails to start correctly
Added incompatible change section
Bugzilla Id: 54414

Modified:
    jmeter/trunk/xdocs/changes.xml
Comment 3 Sebb 2013-01-14 20:16:36 UTC
URL: http://svn.apache.org/viewvc?rev=1433092&view=rev
Log:
Fix text: JMeter now fails if remote engine config fails

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/JMeter.java
    jmeter/trunk/xdocs/changes.xml