Bug 55008

Summary: Add poi-ooxml-schemas-3.9-20121203.jar to TomEE(WEB-INF/lib) unable to start
Product: POI Reporter: Evan Yang <evanyang1120>
Component: POI OverallAssignee: POI Developers List <dev>
Status: RESOLVED INVALID    
Severity: normal CC: evanyang1120
Priority: P2    
Version: 3.9-dev   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description Evan Yang 2013-05-23 05:40:53 UTC
Hi All,
 I created Web project, and add the jar file(poi-ooxml-schemas-3.9-20121203.jar) to TomEE (under WEB-INF/lib).  when TomEE runtime environment is JDK1.7, there is problem during when we start TomEE. Following are details:

SEVERE: A child container failed during start
java.util.concurrent.ExecutionException: java.lang.StackOverflowError
	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:252)
	at java.util.concurrent.FutureTask.get(FutureTask.java:111)
	at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:1123)
	at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:800)
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1559)
	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1549)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.StackOverflowError
	at java.util.zip.ZipCoder.toString(ZipCoder.java:56)
	at java.util.zip.ZipFile.getZipEntry(ZipFile.java:529)
	at java.util.zip.ZipFile.access$900(ZipFile.java:56)
	at java.util.zip.ZipFile$1.nextElement(ZipFile.java:511)
	at java.util.zip.ZipFile$1.nextElement(ZipFile.java:481)
	at java.util.jar.JarFile$1.nextElement(JarFile.java:243)
	at java.util.jar.JarFile$1.nextElement(JarFile.java:238)
	at org.apache.xbean.finder.archive.JarArchive$JarIterator.advance(JarArchive.java:105)
	at org.apache.xbean.finder.archive.JarArchive$JarIterator.advance(JarArchive.java:108)
	at org.apache.xbean.finder.archive.JarArchive$JarIterator.advance(JarArchive.java:108)
	at org.apache.xbean.finder.archive.JarArchive$JarIterator.advance(JarArchive.java:108)
	at org.apache.xbean.finder.archive.JarArchive$JarIterator.advance(JarArchive.java:108)
	at org.apache.xbean.finder.archive.JarArchive$JarIterator.advance(JarArchive.java:108)
	at org.apache.xbean.finder.archive.JarArchive$JarIterator.advance(JarArchive.java:108)
	at org.apache.xbean.finder.archive.JarArchive$JarIterator.advance(JarArchive.java:108)

So, please help me to fix it.

Thank you!
Comment 1 Nick Burch 2013-05-23 09:03:58 UTC
This does not look like a POI problem, it looks like either an xmlbeans one, or one with your appserver