Bug 55902

Summary: Mixed fonts issue with Chinese characters (unable to form images from ppt)
Product: POI Reporter: Amit <amit.sahu89>
Component: XSLFAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: abhinav
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: Other   
OS: All   
Attachments: contains Chinese characters, English characters in two different fonts
[PATCH] Bug 55902 - fallback font renderer

Description Amit 2013-12-18 09:57:38 UTC
Created attachment 31129 [details]
contains Chinese characters, English characters in two different fonts

When mixed fonts are present with chinese characters (like MS Gothic, Calibri) unable to convert ppt to images. For single font in entire file it works fine.
Comment 1 Andreas Beeker 2013-12-24 22:20:10 UTC
Created attachment 31151 [details]
[PATCH] Bug 55902 - fallback font renderer

this patch contains a modified version of the TextPainter which generates an AttributedString with fallback fonts in case the original font can't display the glyphs. this is possible due to unset/default font family settings in the original ppt - also for the Chinese symbols.

Due to upload limitations, the mona font is not included - it can be downloaded at http://sourceforge.net/projects/monafont

(I'll commit this patch when I've finished committing my other uncommitted patches ...)
Comment 2 Andreas Beeker 2014-02-11 23:29:32 UTC
Applied with r1567455
Comment 3 Andreas Beeker 2014-12-20 11:06:45 UTC
*** Bug 54880 has been marked as a duplicate of this bug. ***
Comment 4 Andreas Beeker 2016-12-03 20:34:44 UTC
There was a regression ... the code simply didn't make it into the Common SL rendering.

This was fixed via r1772485