Bug 56124

Summary: A simple expression like "${active eq 1 and newItem ne 'true'}" is throwing an "javax.el.ELException: Failed to parse the expression [${activeeq1andnewItemne'true'}]" error
Product: Tomcat 7 Reporter: Santosh <pansa05>
Component: JasperAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: P2    
Version: 7.0.50   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description Santosh 2014-02-10 08:52:48 UTC
A simple expression like "${active eq 1 and newItem ne 'true'}" is throwing an "javax.el.ELException: Failed to parse the expression [${activeeq1andnewItemne'true'}]" error.

This use to work until version 7.0.47. When I replace the ne with a !=, it seems to work fine again.

I don't see the underlying libraries jasper.jar and jasper-el.jar have changed between these two versions, and hence don't expect this to be a intentional behavior. Please confirm whether or not this is a bug.
Comment 1 Mark Thomas 2014-02-10 09:09:24 UTC

*** This bug has been marked as a duplicate of bug 56029 ***