Bug 56203

Summary: AuthProviderAlias broken in 2.4 whereas was working in 2.2
Product: Apache httpd-2 Reporter: Archie Cobbs <archie>
Component: CoreAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: P2    
Version: 2.4.6   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description Archie Cobbs 2014-02-28 23:23:12 UTC
My configuration using AuthProviderAlias and AuthBasicProvider that worked with Apache 2.2.x stopped working after upgrading to 2.4.x, even after updating the Requires lines.

The problem is that even when correct credentials are provided, apache reports:

  [auth_basic:error] [pid 3132] [client ...] AH01618: user archie not found: /foobar

and the alternative authentication provider that is being specified with AuthBasicProvider is never even invoked.

But thank God for stackoverflow.com... see a technical description of the cause with a patch here:

  http://stackoverflow.com/questions/18874062/can-authnprovideralias-ldap-work-with-apache2-4-x

All I know is that after building a custom version of apache-2.4.6 with this patch, everything worked again.
Comment 1 Eric Covener 2014-03-01 00:55:29 UTC
Queued up for 2.4.8 already

*** This bug has been marked as a duplicate of bug 55622 ***