Bug 56453

Summary: HSSFCellStyle getDataFormatStringCache must be used synchronized
Product: POI Reporter: Bernhard Seebass <seebass>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: P2    
Version: 3.10-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description Bernhard Seebass 2014-04-24 12:35:24 UTC
getDataFormatString may return random results due to the unsynchronized usage of the static fields lastDateFormat, lastFormats and getDataFormatStringCache.

The methods getDataFormatString and cloneStyleFrom should use

synchronized (HSSFCellStyle.class) {
...
}
Comment 1 Dominik Stadler 2014-05-26 20:17:27 UTC
I hopefully just fixed via Bug 56563 albeit a bit differently to avoid the expansive synchronization at this point.

*** This bug has been marked as a duplicate of bug 56563 ***