Bug 56622

Summary: mod_reqtimeout incorrectly applies timeouts to CONNECT requests
Product: Apache httpd-2 Reporter: Stephen Kent <smkent>
Component: mod_reqtimeoutAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: RESOLVED FIXED    
Severity: normal Keywords: FixedInTrunk, PatchAvailable
Priority: P2    
Version: 2.4.10   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
Attachments: Proposed fix for this issue

Description Stephen Kent 2014-06-13 18:03:22 UTC
Created attachment 31715 [details]
Proposed fix for this issue

mod_reqtimeout applies connection timeouts to CONNECT-method requests.

mod_reqtimeout's source suggests this is not the intended behavior.

I have written a short patch to fix this, please see attached.
Comment 1 Will Mortensen 2015-02-13 04:24:03 UTC
Remains unfixed in 2.4, and appears broken in 2.5 too.
Comment 2 Christophe JAILLET 2018-08-03 22:04:34 UTC
An equivalent patch has been applied in r1757675 and is available since 2.4.24.

Commit message points to https://bugzilla.mozilla.org/show_bug.cgi?id=1279483#c9