Bug 56810

Summary: ANT: test target fails
Product: Tomcat 8 Reporter: Asaf <asaf.dalet>
Component: UtilAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: normal CC: asaf.dalet
Priority: P2    
Version: 8.0.x-trunk   
Target Milestone: ----   
Hardware: PC   
OS: All   
Attachments: ANT log showing the problem
patch

Description Asaf 2014-08-04 12:50:13 UTC
Created attachment 31870 [details]
ANT log showing the problem

when trying to run the tests using ANT (ant test), the test fails during compilation. See attached ANT log file.

The problem is in the class TesterOpenSSL which uses the method Process.waitFor(int,TimeUnit). This method does not exist in Java 7 (it was introduced in Java 8).
Comment 1 Asaf 2014-08-04 12:51:56 UTC
Created attachment 31871 [details]
patch

a fix for the problem
Comment 2 Mark Thomas 2014-08-04 15:00:01 UTC
Thanks for the report. The chances of this getting stuck are slim so I went for the simpler fix.