Bug 56972

Summary: Unable to Publish JMS Msg for Tibco EMS using Jmeter Publisher/Subscriber.
Product: JMeter - Now in Github Reporter: NGS <gnanasekaran.n>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: RESOLVED DUPLICATE    
Severity: normal CC: gnanasekaran.n, p.mouawad
Priority: P2    
Version: 2.11   
Target Milestone: ---   
Hardware: All   
OS: All   
Attachments: Jmeter Test Plan script
Jmeter Log file

Description NGS 2014-09-12 00:11:19 UTC
When trying to generate script for testing TIBCO EMS middleware by publishing messages to the JMS queue using JMeter.
The messages don't get published successfully to the queue. It say publish the msg sucessfully. Using Jmeter when we were pointing to TEST, publishing a message to the topic bound to the JNDI name “xxxTopic” (which is mapped to .TEST..xxxx.REQUEST), passing in  JMSReplyTo=TEST.JMTR.xxx.RESPONSE.  
Onthe WebSphere log file and confirmed that the xxx service received the JMSReplyTo property and its value was null. However the no response is received. When checked in the EMS server the messages do have null value for the "JMSReplyTo"string and hence not able to find the Response queue and timing out.
Request you to please provide a possible solution for Tibco JMS testing.
We had taken necessary Tibco Jar files for publishing the msg.
Comment 1 Philippe Mouawad 2014-09-12 20:42:10 UTC
Hello,
Could you show your test plan please ?
And attach jmeter.log file ?

Thank you
Comment 2 NGS 2014-09-16 20:42:58 UTC
Created attachment 32027 [details]
Jmeter Test Plan script
Comment 3 NGS 2014-09-16 20:44:30 UTC
Created attachment 32028 [details]
Jmeter Log file

Here is the log file after the execution of the Test plan
Comment 4 Philippe Mouawad 2014-10-01 19:01:21 UTC
Date: Wed Oct  1 18:57:25 2014
New Revision: 1628809

URL: http://svn.apache.org/r1628809
Log:
Bug 56972 - Unable to Publish JMS Msg for Tibco EMS using Jmeter Publisher/Subscriber.
Fix java.lang.ArithmeticException: / by zero
Bugzilla Id: 56972

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/visualizers/TableSample.java
Comment 5 Philippe Mouawad 2014-10-05 20:24:26 UTC
Hello,
I analysed your issue and found another issue fixed now in nightly build:
https://issues.apache.org/bugzilla/show_bug.cgi?id=57052

Once this issue is fixed, I am not able to reproduce your issue as my tests on ActiveMQ don't show any problem.

I read this:
https://docs.tibco.com/pub/businessevents/5.1.2/doc/html/tib_be_developers_guide/wwhelp/wwhimpl/common/html/wwhelp.htm#href=channels.05.17.htm&single=true

And it seems setting property JMSReplyTo should be fine as per this:
If an event has a string type property named JMSReplyTo (case sensitive), TIBCO BusinessEvents reads this event property value as a JMS queue or topic name, according to the event's default destination type. TIBCO BusinessEvents looks up the javax.jms.Destination on the connected JMS server using this queue or topic name. If TIBCO BusinessEvents cannot find one, it creates a new javax.jms.Destination using the given queue or topic name. TIBCO BusinessEvents then sets the JMSReplyTo header property of the outgoing JMS message using this destination 

Can you try again with nightly build and see it it's working ?
See http://jmeter.apache.org/nightly.html

Installing JMeter runtime
Download the _bin and _lib files
Unpack the archives into the same directory structure
The other archives are not needed to run JMeter. 

Thanks
Comment 6 Philippe Mouawad 2014-11-16 12:59:59 UTC
Closing as we got no feedback after the fix of 57052 and cannot reproduce after the fix.

*** This bug has been marked as a duplicate of bug 57052 ***
Comment 7 The ASF infrastructure team 2022-09-24 20:37:57 UTC
This issue has been migrated to GitHub: https://github.com/apache/jmeter/issues/3432