Bug 57471

Summary: Apache 2.4.10 Compilation fails when compiling against pcre2-10.00
Product: Apache httpd-2 Reporter: Andrew Lane Carr <andrewlanecarr>
Component: BuildAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: NEW ---    
Severity: enhancement CC: bugs, dam
Priority: P2    
Version: 2.4.18   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description Andrew Lane Carr 2015-01-20 22:44:53 UTC
Compilation fails with the following errors when compiling with latest pcre ( full config / make log http://pastebin.com/4t5zuYi5 ):

/usr/local/apr/build-1/libtool --silent --mode=link gcc -std=gnu99  -g -O2 -pthread         -o httpd  modules.lo buildmark.o -export-dynamic server/libmain.la modules/core/libmod_so.la modules/http/libmod_http.la server/mpm/event/libevent.la os/unix/libos.la      /usr/local/apr/lib/libaprutil-1.la -lexpat /usr/local/apr/lib/libapr-1.la -lrt -lcrypt -lpthread 
server/.libs/libmain.a(util_pcre.o): In function `ap_regfree':
/root/httpd-2.4.10/server/util_pcre.c:104: undefined reference to `pcre_free'
server/.libs/libmain.a(util_pcre.o): In function `ap_regname':
/root/httpd-2.4.10/server/util_pcre.c:269: undefined reference to `pcre_fullinfo'
/root/httpd-2.4.10/server/util_pcre.c:271: undefined reference to `pcre_fullinfo'
/root/httpd-2.4.10/server/util_pcre.c:273: undefined reference to `pcre_fullinfo'
server/.libs/libmain.a(util_pcre.o): In function `ap_regexec_len':
/root/httpd-2.4.10/server/util_pcre.c:207: undefined reference to `pcre_exec'
server/.libs/libmain.a(util_pcre.o): In function `ap_regcomp':
/root/httpd-2.4.10/server/util_pcre.c:138: undefined reference to `pcre_compile2'
/root/httpd-2.4.10/server/util_pcre.c:151: undefined reference to `pcre_fullinfo'
collect2: ld returned 1 exit status
make[1]: *** [httpd] Error 1
make[1]: Leaving directory `/root/httpd-2.4.10'
make: *** [all-recursive] Error 1
Comment 1 Syed Ali 2016-01-28 13:50:20 UTC
As we need latest pcre which is pcre2, apache http server unable to recognize.
We dont want to downgrade to pcre.
Comment 2 Eric Covener 2016-01-28 13:51:51 UTC
(In reply to Syed Ali from comment #1)
> As we need latest pcre which is pcre2, apache http server unable to
> recognize.
> We dont want to downgrade to pcre

It's designed as an incompatible version of the library, so you shouldn't look at it is a downgrade.