Bug 57502

Summary: [patch] patch for ant build.xml to ensure creating compile-lib dir
Product: POI Reporter: Konstantin Gribov <grossws>
Component: POI OverallAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description Konstantin Gribov 2015-01-26 17:49:16 UTC
Currently ant build on new repo clone is broken if no `compile-lib` directory exists. Ant fails when trying to download libs which should be placed there.


Patch:

diff --git a/build.xml b/build.xml
index 57ee345..e94fd8d 100644
--- a/build.xml
+++ b/build.xml
@@ -447,6 +447,7 @@ under the License.
     <target name="fetch-jars" depends="check-jars" unless="jars.present"
             description="Fetches needed JAR files from the Internet">
         <mkdir dir="${main.lib}"/>
+        <mkdir dir="${compile.lib}"/>
         <antcall target="downloadfile">
             <param name="sourcefile" value="${main.commons-logging.url}"/>
             <param name="destfile" value="${main.commons-logging.jar}"/>
Comment 1 Dominik Stadler 2015-01-27 15:31:14 UTC
Fixed on trunk as part of Bug 57468, the mkdir actually needs to be in check-jars as it fails already there in the delete-task...

*** This bug has been marked as a duplicate of bug 57468 ***