Bug 57712

Summary: Cloning existing Chart in worksheet to another worksheet: does not work
Product: POI Reporter: palmerr_2002
Component: XSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P2    
Version: 3.11-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description palmerr_2002 2015-03-16 03:25:40 UTC
Hi,
The Apache POI project makes a claim that it can copy/clone information
in and existing workbook/worksheet.

BUT, when I try to copy a worksheet that contains a pre-existing chart (using this as a template) and put this into another worksheet, it does not copy it properly as far as I can tell.
I tried Apache POI 3.9, 3.10, and 3.11,
AND none of these worked.

I hope this can be fixed soon.

Regards,

P
Comment 1 sebastian.novak 2015-03-18 15:37:15 UTC
I support (In reply to palmerr_2002 from comment #0)
> Hi,
> The Apache POI project makes a claim that it can copy/clone information
> in and existing workbook/worksheet.
> 
> BUT, when I try to copy a worksheet that contains a pre-existing chart
> (using this as a template) and put this into another worksheet, it does not
> copy it properly as far as I can tell.
> I tried Apache POI 3.9, 3.10, and 3.11,
> AND none of these worked.
> 
> I hope this can be fixed soon.
> 
> Regards,
> 
> P

I second this as well, we resorted to JFreeChart as there's we didn't find any feasible way to copy the charts from one workbook to another.
Comment 2 Dominik Stadler 2015-03-18 20:26:42 UTC
This is already handled under bug 54470 which has some proposed changes, albeit they are likely not the full solution yet as e.g. the chart-source rows are not properly cloned over. Anyway, further discussion of this should be done in Bug 54470.

*** This bug has been marked as a duplicate of bug 54470 ***