Bug 57991

Summary: Adding image to document .docx not work, both 3.12 and 3.10 versions
Product: POI Reporter: giovannig <giovanni.gaglione>
Component: XWPFAssignee: POI Developers List <dev>
Status: RESOLVED WORKSFORME    
Severity: normal    
Priority: P2    
Version: 3.12-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
Attachments: demo of the code that fails while creating document with image

Description giovannig 2015-06-02 18:40:57 UTC
Created attachment 32786 [details]
demo of the code that fails while creating document with image

I have to build a document .docx that includes an image.
But it does not work.

Attached you find my code.

In the code I try to add both a title and an image.
The result is an empty document.
If I remove the image, than the title is generated inside the document.

How could I fix it?
Comment 1 Michiel 2015-07-13 17:28:56 UTC
I was not able to reproduce this issue. I added a JPEG file from my local machine and it was embedded in the docx file just fine. Would be great if you could attach the image file you used as well as the empty docx. Also, what version of Word did you use?
Comment 2 Dominik Stadler 2016-06-18 05:46:58 UTC
No update for a long time and could not be reproduced easily, therefore closing until more information is provided. Please retry with the latest version and reopen this Bug if it still happens.