Bug 58363

Summary: XSSF writes corrupted XLSX files, cannot be repaired
Product: POI Reporter: Andre Bogus <bogusandre>
Component: XSSFAssignee: POI Developers List <dev>
Status: RESOLVED INVALID    
Severity: regression    
Priority: P2    
Version: 3.12-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
Attachments: diff between known good xlsx and corrupt output

Description Andre Bogus 2015-09-11 07:43:43 UTC
Created attachment 33095 [details]
diff between known good xlsx and corrupt output

Writing an XLSX file using the normal XSSFWorkbook interface spits out a file that is a valid zip file containing valid XML entries. However, both Excel and LibreOffice (5.0) refuse to open or even recover the resulting file.

It used to work with 3.10 and 3.11-beta2 – in fact I have a correct XLSX with the same contents that opens just fine. The diff is attached (I removed lines where only the order of XML attributes was reversed).
Comment 1 Dominik Stadler 2015-09-11 10:17:44 UTC
Which version of Excel is this? 

And can you attach the two documents as well so we can try on other versions of Excel to see if that is a factor here as well.
Comment 2 Andre Bogus 2015-09-11 10:31:18 UTC
This is Excel 2007. Unfortunately I cannot attach the documents because of legal restrictions. I'll see if I can create a minimum test case to show the problem.
Comment 3 Dominik Stadler 2015-09-11 12:56:57 UTC
Also can you try with 3.13-beta1 or a recent nightly build from https://builds.apache.org/view/POI/job/POI/lastSuccessfulBuild/artifact/build/dist/
Comment 4 Andre Bogus 2015-09-11 13:01:54 UTC
Yeah, I should have included that info; I already tested with 3.13beta1. I'll re-check with a nightly and report back, though.
Comment 5 Dominik Stadler 2016-02-14 07:53:44 UTC
No response and no code sample or sample documents so there is currently not enough information to work on this. Please reopen with more info if this is still an issue for you.