Bug 58423

Summary: Apache >= 2.4.8 PCRE_DUPNAMES causes build failure on Red Hat Enterprise Linux 5
Product: Apache httpd-2 Reporter: Takashi Sato <takashi.asfbugzilla>
Component: CoreAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: NEW ---    
Severity: regression    
Priority: P2    
Version: 2.4-HEAD   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description Takashi Sato 2015-09-17 02:29:05 UTC
r1555551 introduced "named groups" feature, and this uses PCRE_DUPNAMES.

PCRE of Red Hat Enterprise Linux / CentOS 5 is 6.6. Yes, this is too old.
PCRE_DUPNAMES is not defined on PCRE 6.6, so causes build failure.

Issues: 

1) Regression
I have not try, but accourding to the changes, 2.4.7 can build on RHEL 5, but 2.4.8 not.

2) Fails on make
"configure" is succeeded, but "make" is failed with unkind message.

3) not documented
I can't find any document that says Apache 2.4 needs PCRE 6.7 and later.



If we should correct the regression, we should apply rpluem's patch
http://mail-archives.apache.org/mod_mbox/httpd-dev/201401.mbox/%3C52CFAC91.5080707@apache.org%3E
and document.
http://mail-archives.apache.org/mod_mbox/httpd-dev/201401.mbox/%3CFD95E1EB-705D-4B57-91E5-A7D8C05DF421@sharp.fm%3E

If we decide not to correct the regression, we should backport r1612921 (and r1612945 ? )