Bug 58427

Summary: JSP spec out - additional elements in implicit.tld
Product: Tomcat 8 Reporter: sungbae_yoon
Component: JasperAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: major    
Priority: P2    
Version: 8.0.x-trunk   
Target Milestone: ----   
Hardware: PC   
OS: Linux   

Description sungbae_yoon 2015-09-18 00:58:11 UTC
in JSP spec. 

JSP.8.4.3

A JSP 2.1 container must consider only
the JSP version and tlib-version specified by an implicit.tld file, and ignore its
short-name element. Any additional elements in an implicit.tld file must cause a
translation error. The JSP version specified in an implicit.tld file

There is no code to check this spec in ImplicitTagLibraryInfo.java
ImplicitTldRuleSet only checks <tlib-version>, <jsp-version>, <short-name>,
doesn't report any error.

and

Do you have any plan to add ExtendedBaseRules in tomcat?
It looks better to use ExtendedBaseRules to fix it in ImplicitTldRuleSet.

Document already have it.(even though it just copy & paste from original digester doc..)
https://tomcat.apache.org/tomcat-8.0-doc/api/org/apache/tomcat/util/digester/package-summary.html
Comment 1 Mark Thomas 2015-09-21 12:20:14 UTC
Thanks for the report.

Fixed in trunk and 8.0.x for 8.0.27 onwards.

A review of the code in 7.0.x suggests that this is already implemented there and that this was a regression intorduced when the XML parsing was refactored for 8.0.x.