Bug 59368

Summary: addColumnLabel is wrong method name
Product: POI Reporter: Gabriel Jones <datasurfer>
Component: XSSFAssignee: POI Developers List <dev>
Severity: enhancement    
Priority: P2    
Version: 3.15-dev   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description Gabriel Jones 2016-04-22 16:37:15 UTC
XSSFPivotTable.addDataColumn should be called addColumnLabel
XSSFPivotTable.addColumnLabel should be called addValue

As it stands these method names are out of harmony with the Excel GUI for manipulating dimensions in a Pivot Table.  The proposed method renaming would bring the GUI and the api into harmony.

Much confusion is to be had under the current naming scheme.
Comment 1 Javen O'Neal 2016-06-17 10:50:52 UTC

*** This bug has been marked as a duplicate of bug 59705 ***