Bug 59643

Summary: ant mvn-install doesn't seem to work
Product: POI Reporter: virtuald <dustin>
Component: POI OverallAssignee: POI Developers List <dev>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description virtuald 2016-05-30 18:43:36 UTC
First problem was that I couldn't get it to recognize the maven ant tasks... looks like the ant distributed with fedora doesn't work for some reason. Using ant 1.9.2 bundled with eclipse seems to have done the trick though.

When I run `ant mvn-install`, I get errors like this:

[mvn:install] An error has occurred while processing the Maven artifact tasks.
[mvn:install]  Diagnosis:
[mvn:install] 
[mvn:install] Error installing artifact 'org.apache.poi:poi:jar': Error installing artifact:/path/to/file.. 

My patch at https://github.com/virtuald/poi/commit/e313a289cc3d3ea2a36229c05347209406512104 fixes this, would like a sanity check that I'm not doing something wrong before I push it into SVN.
Comment 1 Nick Burch 2016-05-31 09:14:27 UTC
Looks like we forgot to update that task when we tweaked the maven pom stuff to make releases easier. Patch fixes things for me, thanks! Applied in r1746257.