Bug 60299

Summary: Thread Group with Scheduler : Weird behaviour when End-Time is in the past
Product: JMeter Reporter: Timo <ASF.Software.Timo>
Component: MainAssignee: JMeter issues mailing list <issues>
Status: CLOSED FIXED    
Severity: major CC: p.mouawad
Priority: P2    
Version: 3.0   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Timo 2016-10-24 06:50:01 UTC
Settings in the Thread-Group:
Sheduler: The Start-Time and End-Time are in the past. 

Now starting the Load-Test: JMeter direct starts the load-test and starts all Thread within the Ramp-Up Time. Every Thread will run exact one time and then end working.

But this behavior is not what I expected.

I think tow options would be correct:

1.) Is at least one of the date in the past (Or End-Time is before Start-Time)
    JMeter shows an error dialog. With a message like: "Start-Time and / or End-Time of Scheduler <Name of Scheduler> are in the past. Please check this values!\Test aborted.".

2.) No Thread would be started, because no thread is allowd to started after End-Time.


IMHO: I would prefer the first option!
Comment 1 Philippe Mouawad 2016-11-12 21:27:01 UTC
Author: pmouawad
Date: Sat Nov 12 21:26:36 2016
New Revision: 1769429

URL: http://svn.apache.org/viewvc?rev=1769429&view=rev
Log:
Bug 60299 - Thread Group with Scheduler : Weird behaviour when End-Time is in the past
Bugzilla Id: 60299

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/threads/ThreadGroup.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Timo 2016-11-30 09:06:36 UTC
I've retested the behavoir.
Thank you for fixing this bug.