Bug 60518

Summary: HSSFCell.Type can not recognize the right type
Product: POI Reporter: Mike Json <iadore>
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED WORKSFORME    
Severity: normal CC: iadore
Priority: P2    
Version: 3.15-FINAL   
Target Milestone: ---   
Hardware: Macintosh   
OS: All   

Description Mike Json 2016-12-26 09:16:21 UTC
type set in word is date type,but in program it became number sometimes or text,really confusing
Comment 1 Javen O'Neal 2016-12-26 18:41:31 UTC
Can you please post an short example of the code that is causing you problems?

Your code should look like this: https://poi.apache.org/spreadsheet/quick-guide.html#CreateDateCells

Note that you CANNOT set a date cell like this:

> cell.setCellValue("12/26/2016");
> cell.setCellType(CellType.DATE);
Comment 2 Javen O'Neal 2017-02-17 04:11:25 UTC
Closing since no response for several months. Please reopen with necessary information to reproduce the problem if you are still experiencing an issue.