Bug 60915

Summary: XLS to HTML Charts not coming
Product: POI Reporter: pooja.dhannawat535
Component: HSSFAssignee: POI Developers List <dev>
Status: RESOLVED INVALID    
Severity: enhancement    
Priority: P2    
Version: 3.15-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description pooja.dhannawat535 2017-03-24 11:22:14 UTC
I am using ExcelToHtmlConverter provided by POI to xls to pdf conversion.
Somehow in the output I am not getting charts. 

I thought of adding one more method in ExcelToHtmlConverter named as processChart by extending the class. Sample method -

 //TODO convert chart to images and add to output
    private void processChart(HSSFSheet sheet) {
        for(HSSFChart chart : HSSFChart.getSheetCharts(sheet)){
            Element table = this.htmlDocumentFacade.createTable();
            this.htmlDocumentFacade.addStyleClass(table, this.cssClassPrefixTable, "border-collapse:collapse;border-spacing:0;");
            Element tableBody = this.htmlDocumentFacade.createTableBody();
            tableBody.setTextContent(chart.getChartTitle());
            table.appendChild(tableBody);
            this.htmlDocumentFacade.getBody().appendChild(table);
        }
    }


Somehow I am not able to convert this HSSFChart to image. Please suggest me a way to convert to chart to image or to add them in final output.
Comment 1 Javen O'Neal 2017-09-19 04:42:20 UTC
I am not sure what the issue is. Sounds like a mixture of a usage question and a feature enhancement request. ExcelToHtmlConverter outputs to HTML, not PDF. POI currently cannot render charts to images. If anyone is interested in improving the charts API, we encourage them to contact us on the mailing list.