Bug 61163

Summary: POI HSSF And XSSF shiftRows bug POI 3.16
Product: POI Reporter: 孟宁 <yuwun>
Component: XSSFAssignee: POI Developers List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal CC: yuwun
Priority: P2    
Version: 3.16-FINAL   
Target Milestone: ---   
Hardware: PC   
OS: All   
Attachments: Befroe ShiftRows
AFter ShiftRows sheet.shiftRows(7, sheet.getLastRowNum(), 1, true, false);

Description 孟宁 2017-06-07 02:42:48 UTC
shiftRows(beginRow,endRow,row)  Please see the attachment
Comment 1 孟宁 2017-06-07 04:15:18 UTC
Created attachment 35034 [details]
Befroe ShiftRows
Comment 2 孟宁 2017-06-07 04:16:10 UTC
Created attachment 35035 [details]
AFter ShiftRows sheet.shiftRows(7, sheet.getLastRowNum(), 1, true, false);
Comment 3 Javen O'Neal 2017-06-07 06:29:38 UTC
Based on the pictures, this looks like an issue with unmerging cells, possibly also an issue with changing the border style, when shifting the rows.

Can you provide a test document before the rows were shifted? This would be helpful to be able to reproduce and develop a fix for this bug. Please remove any sensitive information from the workbook.
Can you clarify whether this problem occurs with xls (HSSF) or xlsx (XSSF)?
Comment 4 Dominik Stadler 2017-08-19 16:38:27 UTC
This is likely fixed again via the changes in #60384, please try with a recent build which includes the changes from r1805518 to verify that it works again for you.

*** This bug has been marked as a duplicate of bug 60384 ***