Bug 61207

Summary: HTTP OPTIONS method shows HEAD multiple times ("GET,HEAD,POST,OPTIONS,HEAD,HEAD")
Product: Apache httpd-2 Reporter: hanno
Component: CoreAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: RESOLVED FIXED    
Severity: normal Keywords: FixedInTrunk
Priority: P2    
Version: 2.4.25   
Target Milestone: ---   
Hardware: PC   
OS: Linux   

Description hanno 2017-06-22 08:44:54 UTC
When using the HTTP OPTIONS method against an apache web server it replies with an "Allow" header that contains "HEAD" three times.

To reproduce:
curl -D - -X OPTIONS http://localhost

Returns:
HTTP/1.1 200 OK
Date: Thu, 22 Jun 2017 08:40:07 GMT
Server: Apache
Allow: GET,HEAD,POST,OPTIONS,HEAD,HEAD
Content-Length: 0
Content-Type: httpd/unix-directory

This certainly doesn't seem correct, it should only list each method once in the "Allow" header.
Comment 1 Christophe JAILLET 2017-06-25 07:13:24 UTC
Fixed in r1799784.
Backport proposal in 2.4.x in r1799787

This looks like a regression in 2.4.24 (unreleased, 2.4.25 and 2.4.26.

Thx for the report.
Comment 2 Yann Ylavic 2017-07-12 13:04:24 UTC
Fixed in 2.4.27 with r1799784.
Comment 3 Yann Ylavic 2017-07-12 13:07:15 UTC
Backport is rather r1799890.